View Issue Details

IDProjectCategoryView StatusLast Update
0008169LazarusIDEpublic2011-10-11 00:26
Reporteruser268Assigned ToVincent Snijders  
PrioritynormalSeveritycrashReproducibilitysometimes
Status resolvedResolutionunable to reproduce 
PlatformLinux 
Product Version0.9.21 (SVN) 
Summary0008169: F9 shortcut sometimes doesnot work correctly
DescriptionSometimes, when project is changed outside IDE or widgetset is changed and Lazarus rebuild, after opening related project .lpi and pressing F9 to run, there is no effect. After activating the same function from menu, project is started to compile and shortly Lazarus is killed with no error report. Only after project is forced to be build by menu function "Build All", F9 compile and run project regulary.

No debugger is enabled.
I strongly suggest applying steps from issue 0001896
TagsNo tags attached.
Fixed in Revision
LazTarget-
WidgetsetGTK 2
Attached Files

Activities

user268

2010-02-06 21:38

  ~0034264

This is still the problem on some platform?

Today, as far I perform testing it did not fail, except sometime (very rarely) will not start debugging on F9.

Zeljan Rikalo

2011-07-04 20:54

developer   ~0049662

@Sasa, I cannot reproduce it under linux gtk2/qt ... is this still reproducable ?

Vincent Snijders

2011-10-11 00:25

manager   ~0052844

No feedback from reporter.

Issue History

Date Modified Username Field Change
2007-01-21 19:24 user268 New Issue
2007-01-21 19:24 user268 Widgetset => GTK 2
2007-01-21 21:50 Vincent Snijders LazTarget => post 1.0
2007-01-21 21:50 Vincent Snijders Status new => acknowledged
2010-02-06 21:38 user268 Note Added: 0034264
2011-07-04 20:54 Zeljan Rikalo LazTarget post 1.0 => -
2011-07-04 20:54 Zeljan Rikalo Note Added: 0049662
2011-07-04 20:54 Zeljan Rikalo Status acknowledged => feedback
2011-10-11 00:25 Vincent Snijders Status feedback => resolved
2011-10-11 00:25 Vincent Snijders Resolution open => unable to reproduce
2011-10-11 00:25 Vincent Snijders Assigned To => Vincent Snijders
2011-10-11 00:25 Vincent Snijders Note Added: 0052844