View Issue Details

IDProjectCategoryView StatusLast Update
0008332LazarusDatabasepublic2011-12-01 10:26
ReporterStefano Assigned ToLuiz Americo  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version0.9.13 (SVN) 
Summary0008332: Problems with Db Float Fields
DescriptionUsing Lazarus and FBDataSet I've meet some problems with Float Fields associated to Db componentes as TDbEdit or TDbGrid:

1) If the user delete the content of a a float field (leaving it blank) an arrour occours: '' is not a valid float. Press Ok to ignore and risk data corruption. Press Cancel to kill the program.

I think the problem is that the field is not setted to Null.

2) Sometimes, with some numbers, there is a problem of precision and in the edit state the number is shown with a large number of decimals, all return ok when the user exit from the edit state.

For example, the number 69,40 in edit state becomes 69,40000000000001, once the user exit from the edit state, the number returns correct (69,40).

I thought of a bug of FBDataSet component and I post this message in the Uib forum:
http://www.progdigy.com/modules.php?name=Forums&file=viewtopic&t=3589

The author of FbDataSet sais it is a bug of Lazaurs, so I've decided to post the message, hoping this could be useful to you.
TagsNo tags attached.
Fixed in Revision
LazTarget-
WidgetsetWin32/Win64
Attached Files

Activities

Vincent Snijders

2007-02-14 10:34

manager   ~0011445

CAn you upload his patch?

2007-02-14 13:29

 

lcl_path.rar (3,478 bytes)

Stefano

2007-02-14 13:36

reporter   ~0011448

I've upload Alexs'patch. However, I've not resolved with this patch that limits only the possibility of blank field using a mask field but doesn't solve the problem.

Besides, the mask is not always useful to use; however after having installed the patch I've noted a changing in the fonts of TEdit, numbers and letters are written more in the bottom of the TEdit so sometimes the bottom part of the characters is hidden.

The patch doesn't solve at all the problem in TDbGrid and doesn't solve the precision problem. For this I've preferred to not use this patch.

Luiz Americo

2011-05-09 19:32

developer   ~0048160

I tested with Lazarus 0.9.31 r28168 FPC 2.4.2 i386-win32-win32/win64 and both issues are not present anymore.

Can you test and post an example if the bug is still present?

Luiz Americo

2011-05-16 01:46

developer   ~0048325

Seems to be fixed in the mean time

Issue History

Date Modified Username Field Change
2007-02-14 10:10 Stefano New Issue
2007-02-14 10:10 Stefano Widgetset => Win32
2007-02-14 10:34 Vincent Snijders LazTarget => post 1.0
2007-02-14 10:34 Vincent Snijders Note Added: 0011445
2007-02-14 10:34 Vincent Snijders Status new => feedback
2007-02-14 13:29 Stefano File Added: lcl_path.rar
2007-02-14 13:36 Stefano Note Added: 0011448
2007-02-14 14:49 Vincent Snijders Status feedback => acknowledged
2010-07-21 11:53 Felipe Monteiro de Carvalho LazTarget post 1.0 => -
2010-07-21 11:53 Felipe Monteiro de Carvalho Category LCL => Database
2011-04-21 19:32 Luiz Americo Status acknowledged => assigned
2011-04-21 19:32 Luiz Americo Assigned To => Luiz Americo
2011-05-09 19:32 Luiz Americo Note Added: 0048160
2011-05-09 19:32 Luiz Americo Status assigned => feedback
2011-05-16 01:46 Luiz Americo Status feedback => resolved
2011-05-16 01:46 Luiz Americo Resolution open => fixed
2011-05-16 01:46 Luiz Americo Note Added: 0048325
2011-12-01 10:26 Marc Weustink Status resolved => closed