View Issue Details

IDProjectCategoryView StatusLast Update
0008333LazarusLCLpublic2011-06-29 20:41
ReporterGraeme Geldenhuys Assigned ToZeljan Rikalo  
PrioritynormalSeverityfeatureReproducibilityalways
Status resolvedResolutionnot fixable 
Platformi386OSUbuntu Linux 
Product Version0.9.21 (SVN) 
Summary0008333: TListView - RowSelect doesn't work
DescriptionSee attached project. Under Linux with Gtk1 the RowSelect property has no affect. Enabled or Disabled, the ListView always shows the whole row as selected. Under Windows it is the opposite. Even if RowSelect is True you can only select a item by clicking on the item in the first column. Under Windows the whole row is never painted as selected even with RowSelect = True.
Steps To ReproduceSee attached project. RowSelect has been enabled, but under Windows you cannot select a row if you don't click on the first column. Even then the whole row doesn't show selected, only the first item.

Under Linux. Change RowSelect = False and run the application (tested with Gtk1). Select a item and the whole row is selected - the opposite of what happens in Windows. The RowSelect makes no difference under Linux.
TagsNo tags attached.
Fixed in Revision
LazTarget0.99.0
WidgetsetGTK 2
Attached Files

Relationships

related to 0014985 closedFelipe Monteiro de Carvalho TListView.RowSelect:=True doesn't work on Windows CE 

Activities

2007-02-14 11:10

 

listviewbug.tar.gz (2,054 bytes)

Felipe Monteiro de Carvalho

2009-11-12 14:41

developer   ~0032079

It works with Lazarus 0.9.29 in Win32 and WinCE.

Zeljan Rikalo

2011-04-07 14:29

developer   ~0047321

Changed target to 0.99, and only to Gtk2, since there's posibility that we must set this as gtk2 issue.

Zeljan Rikalo

2011-06-20 17:12

developer   ~0049238

Yes, no way to change this under gtk/gtk2 ... this should be set as an gtk/gtk2 issue.

Zeljan Rikalo

2011-06-29 20:41

developer   ~0049510

I've spent some time over this issue, but I'm afraid it's not possible to fix this for gtk2.

Issue History

Date Modified Username Field Change
2007-02-14 11:10 Graeme Geldenhuys New Issue
2007-02-14 11:10 Graeme Geldenhuys File Added: listviewbug.tar.gz
2007-02-14 11:10 Graeme Geldenhuys Widgetset => GTK, Win32
2007-02-14 11:19 Vincent Snijders LazTarget => post 1.0
2007-02-14 11:19 Vincent Snijders Status new => acknowledged
2007-02-14 11:19 Vincent Snijders Severity major => feature
2009-11-10 19:02 Felipe Monteiro de Carvalho Relationship added related to 0014985
2009-11-12 14:41 Felipe Monteiro de Carvalho Note Added: 0032079
2011-04-07 14:29 Zeljan Rikalo LazTarget post 1.0 => 0.99.0
2011-04-07 14:29 Zeljan Rikalo Widgetset GTK, Win32/Win64 => GTK 2
2011-04-07 14:29 Zeljan Rikalo Note Added: 0047321
2011-06-20 17:12 Zeljan Rikalo Note Added: 0049238
2011-06-20 17:12 Zeljan Rikalo Status acknowledged => confirmed
2011-06-29 20:41 Zeljan Rikalo Status confirmed => resolved
2011-06-29 20:41 Zeljan Rikalo Resolution open => not fixable
2011-06-29 20:41 Zeljan Rikalo Assigned To => Zeljan Rikalo
2011-06-29 20:41 Zeljan Rikalo Note Added: 0049510