View Issue Details

IDProjectCategoryView StatusLast Update
0008346LazarusIDEpublic2009-06-13 12:10
ReporterCharl van Jaarsveldt Assigned ToZeljan Rikalo  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version0.9.21 (SVN) 
Target Version1.0.0 
Summary0008346: TPageControl: Edit components are invisible - possible z-order problem
DescriptionI have a TPageControl. Add a TTabSheet, and then another. Now I add some components to open sheet - works well. Now I switch to the other tabsheet - either by clicking on the tab or by right-click -> Show Page, then try to add a TEdit component. The component seems to be invisible - apart from the grid-dots that disappears where the component is.

This only happens with some components - TLabel for instance does not appear invisible.

Happens in both gtk and gtk2.
Additional InformationI can get around it by doing the design for one sheet, then switch to the next sheet I want to work on, save the project, restart lazarus and it will open in the other sheet, so I can design that one. It is rather annoying though.
TagsNo tags attached.
Fixed in Revision
LazTarget1.0
WidgetsetGTK, GTK 2
Attached Files

Relationships

related to 0000964 acknowledged GTK2 seems to paint in reverse order...? 

Activities

Charl van Jaarsveldt

2007-02-16 18:11

reporter   ~0011508

This is not just in TPageControl, also got the same thing in TNotebook

Marc Weustink

2007-02-19 10:50

administrator   ~0011543

Did the problem happen in a recent SVN version (say the last 4 weeks) and did it work before ?

Charl van Jaarsveldt

2007-02-27 23:14

reporter   ~0011676

I haven't been using lazarus for a while -- only started doing a project in it again about a month ago, maybe not even a month and I had this problem since then.

Charl

2007-06-18 16:36

reporter   ~0013247

Marc, sorry for long time to respond. I have no idea when it started. I haven't used lazarus for a while, and then when I started with it again I used it in gtk2 and didn't use the notebook or page control straight away. So sorry I don't really have an answer for you.

Charl

2007-06-18 16:39

reporter   ~0013248

Sorry, I didn't notice I already responded to the questions ages ago!

Zeljan Rikalo

2009-02-14 12:02

developer   ~0025390

I've just tested with r 18681, and cannot reproduce it (gtk/gtk2).
If someone can, then please give feedback and example how it happens - in next two weeks, otherwise case will be closed ;)

Zeljan Rikalo

2009-03-25 08:10

developer   ~0026368

No response from reporter. This works ok, so closing.

Issue History

Date Modified Username Field Change
2007-02-15 16:15 Charl van Jaarsveldt New Issue
2007-02-15 16:15 Charl van Jaarsveldt Widgetset => GTK, GTK 2
2007-02-15 16:54 Vincent Snijders LazTarget => 1.0
2007-02-15 16:54 Vincent Snijders Status new => acknowledged
2007-02-16 18:11 Charl van Jaarsveldt Note Added: 0011508
2007-02-19 10:50 Marc Weustink Note Added: 0011543
2007-02-19 10:50 Marc Weustink Assigned To => Marc Weustink
2007-02-19 10:50 Marc Weustink Status acknowledged => feedback
2007-02-27 23:14 Charl van Jaarsveldt Note Added: 0011676
2007-03-09 01:50 Marc Weustink Status feedback => acknowledged
2007-06-18 16:36 Charl Note Added: 0013247
2007-06-18 16:39 Charl Note Added: 0013248
2008-02-09 23:50 Felipe Monteiro de Carvalho Relationship added related to 0000964
2008-04-24 09:57 Vincent Snijders Target Version => 1.0.0
2008-05-25 20:12 Vincent Snijders Assigned To Marc Weustink =>
2009-02-14 12:02 Zeljan Rikalo Note Added: 0025390
2009-02-14 12:02 Zeljan Rikalo Status acknowledged => feedback
2009-03-25 08:10 Zeljan Rikalo Status feedback => resolved
2009-03-25 08:10 Zeljan Rikalo Resolution open => fixed
2009-03-25 08:10 Zeljan Rikalo Assigned To => Zeljan Rikalo
2009-03-25 08:10 Zeljan Rikalo Note Added: 0026368
2009-06-13 12:10 Marc Weustink Status resolved => closed