View Issue Details

IDProjectCategoryView StatusLast Update
0000086Lazaruspublic2002-12-27 03:57
ReporterBug ImportAssigned ToMattias Gaertner 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product VersionProduct Build 
Target VersionFixed in Version 
Summary0000086: Unitialised variables and memory leak
Description1) In TGtkObject.InitStockItems the function CreateBrushIndirect is called. logbrush.lbStyle is set to bs_null , but logbrush.lbColor is not set and is therefor unitialised. lbColor should be set because it is used in CreateBrushIndirect in a call to GetGDIolorRef

2) TGtkObject.FillScreenFont, memory leak
XFreeFontNames(theFonts) should be added.

3) TGtkObject.SelectClipRgn.
The first lines of this routine is:

if not isValidDc(DC) then
  Result := Error;
if Result <> Error then

This should be something like:

Error := 0
if not IsValidDc(DC) then
    Result := Error;
if Result <> Error then
Additional InformationImported information
--------------------
Name: Jeroen van Iddekinge
Mail: iddekingej (at) lycos.com
TagsNo tags attached.
Fixed in Revision
LazTarget
WidgetsetGTK, Win32/Win64
Attached Files

Activities

Bug Import

2002-12-27 03:57

reporter   ~0000068

MG

Issue History

Date Modified Username Field Change
2002-10-28 00:00 Bug Import New Issue
2002-10-28 00:00 Bug Import Widgetset => GTK, Win32
2002-12-27 03:57 Bug Import Status new => assigned
2002-12-27 03:57 Bug Import Assigned To => Mattias Gaertner
2002-12-27 03:57 Bug Import Note Added: 0000068
2002-12-27 03:57 Bug Import Status new => closed
2002-12-27 03:57 Bug Import Resolution open => fixed