View Issue Details

IDProjectCategoryView StatusLast Update
0008609LazarusIDEpublic2009-10-23 00:39
ReporterGraeme Geldenhuys Assigned ToVincent Snijders  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionunable to reproduce 
Platformi386OSUbuntu Linux 
Product Version0.9.21 (SVN) 
Target Version1.0.0 
Summary0008609: ComboBox in Object Inspector show one item only
DescriptionAny property in the Object Inspector that get presented with a ComboBox only shows one item in the dropdown on the first click. The item show is always the first item, not even the selected item. I have to close and then reopen the dropdown again to show all the items in the dropdown list. See both images attached.

This happens on any property show as a ComboBox. This doesn't happen on every single click, but normally reproducible within 20 or so attempts. A restart of Lazarus makes it reproducible even quicker, after it's done it one. I lived with it for some time (few months now), but now it's getting a bit annoying and thought I would submit a bug report.

This doesn't seem to occur on my co-workers Windows PC, so seems to be a GTK issue only.
TagsNo tags attached.
Fixed in Revision
LazTarget1.0
WidgetsetGTK
Attached Files

Relationships

related to 0012315 closedPaul Ishenin Tlabel.autosize has only one value in object inspector 

Activities

2007-04-02 15:01

 

ObjectInspector.png (7,718 bytes)   
ObjectInspector.png (7,718 bytes)   

2007-04-02 15:02

 

ObjectInspector1.png (7,491 bytes)   
ObjectInspector1.png (7,491 bytes)   

Zeljan Rikalo

2009-02-11 22:57

developer   ~0025300

Graeme, I've clicked almost 10 minutes inside OI but cannot reproduce this issue.
Can you confirm that ?

Zeljan Rikalo

2009-02-13 10:03

developer   ~0025334

Graeme, pls check this one :)

2009-02-13 10:27

 

Screenshot-1.png (63,350 bytes)   
Screenshot-1.png (63,350 bytes)   

2009-02-13 10:27

 

Screenshot-2.png (63,249 bytes)   
Screenshot-2.png (63,249 bytes)   

Graeme Geldenhuys

2009-02-13 10:31

reporter   ~0025336

It seems to occur less that in 2007, but it still occurs. Please note, that this only seems to happen in GTK1, not GTK2. I also seem to have better success in duplicating the issue with Boolean properties.

* Select the Form
* Click on the "down arrow" part of Boolean properties.
* Keep clicking between different properties. I can reproduce this quite quickly.

See two attached screenshots.

Zeljan Rikalo

2009-02-13 11:15

developer   ~0025338

I see, but I cannot reproduce it on my machine (gtk1).Clicking almost 10 minutes and it does not happened.

Graeme Geldenhuys

2009-02-13 11:59

reporter   ~0025340

Maybe it should then be marked as "will not be fixed" and "not reproducible". After all, the default widget set is now GTK2 and less and less people are using GTK1 - as the GTK2 widget set becomes more usable. Just a thought. ;-)

Issue History

Date Modified Username Field Change
2007-04-02 15:01 Graeme Geldenhuys New Issue
2007-04-02 15:01 Graeme Geldenhuys File Added: ObjectInspector.png
2007-04-02 15:01 Graeme Geldenhuys Widgetset => GTK
2007-04-02 15:02 Graeme Geldenhuys File Added: ObjectInspector1.png
2007-04-02 15:25 Vincent Snijders LazTarget => 1.0
2007-04-02 15:25 Vincent Snijders Status new => acknowledged
2008-04-24 09:57 Vincent Snijders Target Version => 1.0.0
2008-10-08 15:26 Vincent Snijders Relationship added related to 0012315
2009-02-11 22:57 Zeljan Rikalo Note Added: 0025300
2009-02-11 22:57 Zeljan Rikalo Status acknowledged => feedback
2009-02-13 10:03 Zeljan Rikalo Note Added: 0025334
2009-02-13 10:27 Graeme Geldenhuys File Added: Screenshot-1.png
2009-02-13 10:27 Graeme Geldenhuys File Added: Screenshot-2.png
2009-02-13 10:31 Graeme Geldenhuys Note Added: 0025336
2009-02-13 11:15 Zeljan Rikalo Note Added: 0025338
2009-02-13 11:59 Graeme Geldenhuys Note Added: 0025340
2009-04-21 12:23 Vincent Snijders Status feedback => resolved
2009-04-21 12:23 Vincent Snijders Resolution open => unable to reproduce
2009-04-21 12:23 Vincent Snijders Assigned To => Vincent Snijders
2009-10-23 00:39 Marc Weustink Status resolved => closed