View Issue Details

IDProjectCategoryView StatusLast Update
0008855LazarusIDEpublic2019-09-09 19:45
ReporterEmil BeliAssigned To 
PrioritynormalSeverityminorReproducibilityalways
Status acknowledgedResolutionreopened 
PlatformPCOSLinuxOS VersionSuSE 10
Product Version0.9.23 (SVN)Product Build 
Target VersionFixed in Version 
Summary0008855: Editor does not support fully international keyboard layout
DescriptionI am normally using US keyboard with US-intl layout. I have a problem because it won't put apostrophe ' at all.
I need to change to GB keyboard (default GB) in order to be able to write string, because of apostrophes. With normal US layout works properly, but not with intl.

I think there is a catch because intl, on special characters as ' " ^ ~ expects another character behind in order to present letter. When I press ~ and press space, I get ~ If I want à then I press ~ and immedately press A
Maybe this explanation helps.
TagsNo tags attached.
Fixed in Revision
LazTarget-
WidgetsetGTK 2
Attached Files

Relationships

duplicate of 0001186 closedMarc Weustink "Key combos" do not work on the source code editor on gtk 
duplicate of 0007017 closedBart Broersma Accents and Ñ (capital n with tilde) doesn't work in editor 
related to 0015688 feedbackZeljan Rikalo Gtk2 native controls fails to input some chars (dead keys) in Ubuntu Lucid 
has duplicate 0007742 closedBart Broersma SynEdit cannot write accent chars even with font.CharSet = UNICODE 
has duplicate 0009755 closedVincent Snijders Entering single quote character from keyboard becomes A´ in Editor. 
related to 0030871 new Cannot type accents in the source editor 

Activities

Bart Broersma

2009-12-02 11:57

developer   ~0032657

I think this has been fixed in the meantime, with LCL now fully supporting UTF8?

Bart Broersma

2010-02-22 12:45

developer   ~0034667

No feedback from reporter.
Seems to be fixed in the meantime.
Please test and close if fixed, or re-open if issue remains.

Flávio Etrusco (notifications not working)

2010-02-22 21:53

developer   ~0034684

Last edited: 2019-09-09 19:45

View 2 revisions

I'd say this bug isn't fixed. Or at least I have a very similar one:
0015688

Bart Broersma

2010-02-23 01:31

developer   ~0034689

Re-opend at request of Flavio

Issue History

Date Modified Username Field Change
2007-05-12 04:34 Emil Beli New Issue
2007-05-12 04:34 Emil Beli Widgetset => GTK 2
2007-05-13 00:10 Vincent Snijders LazTarget => 1.2
2007-05-13 00:10 Vincent Snijders Status new => acknowledged
2008-06-09 04:49 Felipe Monteiro de Carvalho Relationship added duplicate of 0001186
2008-06-09 04:49 Felipe Monteiro de Carvalho Relationship added duplicate of 0007017
2009-12-02 11:57 Bart Broersma Note Added: 0032657
2009-12-02 11:57 Bart Broersma Status acknowledged => feedback
2009-12-02 12:00 Bart Broersma Relationship added has duplicate 0007742
2009-12-02 12:07 Bart Broersma Relationship added has duplicate 0009755
2010-02-22 12:45 Bart Broersma Status feedback => resolved
2010-02-22 12:45 Bart Broersma Resolution open => fixed
2010-02-22 12:45 Bart Broersma Assigned To => Bart Broersma
2010-02-22 12:45 Bart Broersma Note Added: 0034667
2010-02-22 21:53 Flávio Etrusco (notifications not working) Note Added: 0034684
2010-02-23 01:31 Bart Broersma Assigned To Bart Broersma =>
2010-02-23 01:31 Bart Broersma Status resolved => assigned
2010-02-23 01:31 Bart Broersma Resolution fixed => reopened
2010-02-23 01:31 Bart Broersma Note Added: 0034689
2010-02-23 01:32 Bart Broersma Relationship added related to 0015688
2010-02-23 13:07 Bart Broersma Status assigned => acknowledged
2014-01-14 15:16 Martin Friebe LazTarget 1.2 => 1.4
2014-09-10 00:59 Juha Manninen LazTarget 1.4 => -
2016-11-08 17:50 Martin Friebe Relationship added related to 0030871
2019-09-09 19:45 Bart Broersma Note Edited: 0034684 View Revisions