View Issue Details

IDProjectCategoryView StatusLast Update
0008857LazarusLCLpublic2013-12-07 14:03
ReporterIgor Tolstov Assigned ToBart Broersma 
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Product Version0.9.22Product Build 
Target Version1.2.0Fixed in Version1.2.0 
Summary0008857: TCalendar on show reset to first day of mounth
Descriptioncreate project, 2 form
on first form
one Tbutton on click show_modal second form
on second form
TCalendar and Tbutton whith modal result mrOk

on first show form2, TCalendar show and return current date
on second and other , TCalendar show first day of mounth

TagsNo tags attached.
Fixed in Revision
LazTarget1.2
WidgetsetGTK 2
Attached Files

Relationships

related to 0010190 closedPaul Ishenin TCalendar crash when activating dsShowWeekNumbers through OI 
related to 0021859 closedJuha Manninen Calendar control reports first instead of last day of month. 

Activities

Paul Ishenin

2007-05-12 12:27

manager   ~0012592

Please attach your test application to this report.

2007-05-12 23:06

 

caltest.tar.bz2 (2,355 bytes)

Zeljan Rikalo

2010-05-29 11:48

developer   ~0038124

Bug still exists with Lazarus 0.9.29 r25746M FPC 2.4.1 i386-linux-gtk 2 (beta)

Zeljan Rikalo

2010-05-29 11:49

developer   ~0038125

Gtk is suspended, so flagging as gtk2 since bug still exists.

Gerard V

2010-12-29 18:11

reporter   ~0044690

The behaviour has changed and this seems to be fixed but IMHO it is still incorrect.
If I set the Date property to today's date, the first time it shows with today's date, and any time after that it shows with today's date. The problem is that if I select some other date and close, next time it will show up with today's date instead of the date I selected. Since Form2 is not destroyed, only hidden, controls on it should keep their state.
If I drop a TEdit on Form2, it will keep any change I make in the edited text between calls to ShowModal/Close, and I think a TCalendar should behave in the same way.

Bart Broersma

2012-01-09 00:48

developer   ~0055603

It behaves that way on Windows too.
Not sure if this is Delphi compatible (D3 doesn't implement TCalendar as a native OS widget).

Bart Broersma

2013-11-02 22:00

developer   ~0071105

Last edited: 2013-11-02 22:09

View 2 revisions

For Windows this bug seems to be fixed.
(Lazarus 1.3 r43336 FPC 2.6.2 i386-win32-win32/win64)

[Edit] I also cannot reproduce it on Linux GTK2.
(Lazarus 1.3 r42948 FPC 2.6.2 i386-linux-gtk 2)

Can you please test with current trunk?

Bart Broersma

2013-12-07 14:03

developer   ~0071803

No feedback.
Seems to be fixed.
Please close (or re-open if not fixed).

Issue History

Date Modified Username Field Change
2007-05-12 09:52 Igor Tolstov New Issue
2007-05-12 09:52 Igor Tolstov Widgetset => GTK
2007-05-12 12:27 Paul Ishenin Note Added: 0012592
2007-05-12 12:28 Paul Ishenin LazTarget => -
2007-05-12 12:28 Paul Ishenin Status new => acknowledged
2007-05-12 23:06 Igor Tolstov File Added: caltest.tar.bz2
2007-05-16 16:14 Vincent Snijders LazTarget - => 1.0
2008-04-24 09:57 Vincent Snijders Target Version => 1.0.0
2010-05-29 11:48 Zeljan Rikalo Note Added: 0038124
2010-05-29 11:48 Zeljan Rikalo Status acknowledged => confirmed
2010-05-29 11:49 Zeljan Rikalo Widgetset GTK => GTK 2
2010-05-29 11:49 Zeljan Rikalo Note Added: 0038125
2010-12-20 13:37 Juha Manninen Relationship added related to 0010190
2010-12-29 18:11 Gerard V Note Added: 0044690
2012-01-09 00:48 Bart Broersma Note Added: 0055603
2012-02-04 11:09 Zeljan Rikalo LazTarget 1.0 => 1.2
2012-03-13 07:50 Vincent Snijders Target Version 1.0.0 => 1.2.0
2012-09-09 17:28 Juha Manninen Relationship added related to 0021859
2013-11-02 22:00 Bart Broersma Note Added: 0071105
2013-11-02 22:09 Bart Broersma Note Edited: 0071105 View Revisions
2013-11-02 22:09 Bart Broersma Status confirmed => feedback
2013-12-07 14:03 Bart Broersma Note Added: 0071803
2013-12-07 14:03 Bart Broersma Status feedback => resolved
2013-12-07 14:03 Bart Broersma Fixed in Version => 1.2.0
2013-12-07 14:03 Bart Broersma Resolution open => fixed
2013-12-07 14:03 Bart Broersma Assigned To => Bart Broersma