View Issue Details

IDProjectCategoryView StatusLast Update
0000089Lazaruspublic2002-11-03 15:56
ReporterBug Import Assigned ToMattias Gaertner  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Summary0000089: Bogus IF
Descriptionin TGtkObject.SendPaintMessageForInternalWidgets Contains
(After the nested routines, in the main part):
With Context do begin
    MainWidget := PGTkWidget..
    if MainWidget = nil then exit
    if MainWindow <> nil then
        MainWIndow := ......
    else
       exit

The 'if MainWindow <> nil then' is I think wrong because this variable is not yet initialized. This should be (I think)

With Context do begion
     MainWidget := PGtkWidget...
     if MainWidget = nil then exit;
     MainWidget := ....
Additional InformationImported information
--------------------
Name: Jeroen van Iddekinge
Mail: iddekingej (at) lycos.com
TagsNo tags attached.
Fixed in Revision
LazTarget
WidgetsetGTK, Win32/Win64
Attached Files

Activities

Bug Import

2002-11-03 15:56

reporter   ~0000071

MG

Issue History

Date Modified Username Field Change
2002-11-03 00:00 Bug Import New Issue
2002-11-03 15:56 Bug Import Widgetset => GTK, Win32
2002-11-03 15:56 Bug Import Status new => assigned
2002-11-03 15:56 Bug Import Assigned To => Mattias Gaertner
2002-11-03 15:56 Bug Import Note Added: 0000071
2002-11-03 15:56 Bug Import Status new => closed
2002-11-03 15:56 Bug Import Resolution open => fixed