View Issue Details

IDProjectCategoryView StatusLast Update
0009049LazarusLCLpublic2008-10-16 01:06
ReporterTomasz Wojtyś Assigned ToVincent Snijders  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionunable to reproduce 
Product Version0.9.23 (SVN) 
Summary0009049: ScrollBox wrong ScrollBars position
DescriptionIf you put some controls in to ScrollBox and some of them is out of left edge or top of ScrollBox and you set AutoScroll to True then ScrollBars are in wrong positions becouse you cannot move it to place when you see all putted controls.
Tagsgtk2
Fixed in Revision
LazTarget1.2
WidgetsetGTK 2
Attached Files

Relationships

related to 0010952 closedVincent Snijders Strange scrolling in grids 
has duplicate 0010390 closedZeljan Rikalo Arrow buttons from scrollbar's both edge on tscrollbox don't work 
has duplicate 0009336 closedFelipe Monteiro de Carvalho TScrollBox. Scrollbars arrows do not work. 
related to 0010779 closedZeljan Rikalo TScrolledWinControl does not scroll correctly non TWinControl childs under gtk2 
related to 0011010 closedAles Katona TScrollBox color change applies to only viewable area. 

Activities

Felipe Monteiro de Carvalho

2008-04-16 02:20

developer   ~0018839

Please provide a test project.

Vincent Snijders

2008-05-23 12:10

manager   ~0019624

No feedback from reporter.

Issue History

Date Modified Username Field Change
2007-06-10 13:59 Tomasz Wojtyś New Issue
2007-06-10 13:59 Tomasz Wojtyś Widgetset => GTK 2
2007-06-10 15:28 Vincent Snijders LazTarget => 1.2
2007-06-10 15:28 Vincent Snijders Status new => acknowledged
2008-04-12 12:31 Felipe Monteiro de Carvalho Tag Attached: gtk2
2008-04-16 02:20 Felipe Monteiro de Carvalho Note Added: 0018839
2008-04-16 02:20 Felipe Monteiro de Carvalho Status acknowledged => feedback
2008-04-16 02:28 Felipe Monteiro de Carvalho Relationship added has duplicate 0010390
2008-04-16 02:28 Felipe Monteiro de Carvalho Relationship added duplicate of 0009336
2008-04-16 02:45 Felipe Monteiro de Carvalho Relationship replaced has duplicate 0009336
2008-04-16 16:12 Felipe Monteiro de Carvalho Relationship added related to 0010952
2008-04-16 16:12 Felipe Monteiro de Carvalho Relationship added related to 0010779
2008-04-16 18:48 Felipe Monteiro de Carvalho Relationship added related to 0011010
2008-05-23 12:10 Vincent Snijders Status feedback => resolved
2008-05-23 12:10 Vincent Snijders Resolution open => unable to reproduce
2008-05-23 12:10 Vincent Snijders Assigned To => Vincent Snijders
2008-05-23 12:10 Vincent Snijders Note Added: 0019624
2008-10-16 01:06 Ivo Steinmann Status resolved => closed