View Issue Details

IDProjectCategoryView StatusLast Update
0009195LazarusLCLpublic2013-09-03 12:07
Reporterequinox Assigned ToMartin Friebe  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
PlatformWindowsOSXP 
Product Version0.9.23 (SVN) 
Target Version1.0.0Fixed in Version0.9.27 (SVN) 
Summary0009195: enter is not passed in onkeypress in synedit
DescriptionEnter 0000013 is not passed in onkeypress event in Synedit.
TagsNo tags attached.
Fixed in Revision20009
LazTarget1.4
Widgetset
Attached Files

Activities

Vincent Snijders

2007-07-02 09:25

manager   ~0013528

As far as I can see, this bug doesn't hurt Lazarus functionality.

equinox

2007-07-02 10:11

reporter   ~0013533

What are you implying?

Vincent Snijders

2007-07-02 10:19

manager   ~0013534

That this is a low priority bug, because you don't notice it, when using the Lazarus editor, but only if you are using the synedit component in your own programs.

Martin Friebe

2009-05-17 15:41

manager   ~0027655

The intended behaviour is now:

- Anything assigned in KeyStrokes in *not* triggering OnKeyPressed.
- By Default this applies to the "Enter key", and "Ctrl-M"

You can remove both of them from Keystrokes. If you do so, they will be passed on in OnKeyPressed.
However, if you do so chr13 is a simple Newline; that is, it will insert a new line, but anything else that Synedit normally does with a new line(like indent) will not be done.

If you do disagree with the intended behaviour, please use the mailing list to discuss this.

If the described behaviour is fine for you, please test and close the issue if ok

Issue History

Date Modified Username Field Change
2007-07-01 16:33 equinox New Issue
2007-07-01 16:33 equinox Widgetset => GTK
2007-07-02 09:25 Vincent Snijders LazTarget => post 1.2
2007-07-02 09:25 Vincent Snijders Note Added: 0013528
2007-07-02 09:25 Vincent Snijders Status new => acknowledged
2007-07-02 10:11 equinox Note Added: 0013533
2007-07-02 10:19 Vincent Snijders Note Added: 0013534
2009-01-12 16:48 Martin Friebe Status acknowledged => assigned
2009-01-12 16:48 Martin Friebe Assigned To => Martin Friebe
2009-05-17 15:41 Martin Friebe Fixed in Revision => 20009
2009-05-17 15:41 Martin Friebe Widgetset GTK =>
2009-05-17 15:41 Martin Friebe Status assigned => resolved
2009-05-17 15:41 Martin Friebe Fixed in Version => 0.9.27 (SVN)
2009-05-17 15:41 Martin Friebe Resolution open => fixed
2009-05-17 15:41 Martin Friebe Note Added: 0027655
2009-05-17 15:41 Martin Friebe Target Version => 1.0.0
2009-10-23 00:39 Marc Weustink Status resolved => closed
2013-09-03 12:07 Martin Friebe LazTarget post 1.2 => 1.4