View Issue Details

IDProjectCategoryView StatusLast Update
0009755LazarusIDEpublic2010-04-23 11:23
ReporterElphiAssigned ToVincent Snijders 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionno change required 
Product Version0.9.23 (SVN)Product Build 
Target Version1.0.0Fixed in Version 
Summary0009755: Entering single quote character from keyboard becomes A´ in Editor.
Descriptionrev 12084 (20.09.07) fpc 2.2.0 x86_64-gtk.

When I enter a single quote character "'" it is displayed as: "A" FOLLOWED by an acute accent.
The compiler complains with: illegal character "'Â'" ($C2)
  
TagsNo tags attached.
Fixed in Revision
LazTarget1.0
WidgetsetGTK
Attached Files

Relationships

duplicate of 0007742 closedBart Broersma SynEdit cannot write accent chars even with font.CharSet = UNICODE 
duplicate of 0007017 closedBart Broersma Accents and Ñ (capital n with tilde) doesn't work in editor 
duplicate of 0008855 acknowledged Editor does not support fully international keyboard layout 
duplicate of 0001186 closedMarc Weustink "Key combos" do not work on the source code editor on gtk 

Activities

Thaddy de Koning

2007-09-23 14:48

reporter   ~0014863

Last edited: 2007-09-23 14:50

This is not an FPC or Lazarus bug at all, but a system wide keyboard setting that enables complex characters to be composed by combining keystrokes. You can
- Either turn that off
- Or hit space before you type the A
I checked this on Windows, but this feature is also available for Linux in some configurations.

Vincent Snijders

2007-09-23 18:30

manager   ~0014866

Can you try Thaddy's suggestions.

Elphi

2007-09-24 00:23

reporter   ~0014872

If I understand them, I'll surely give it a try. I'll consult linux guru's on the first one. With respect to the second one: I don't want to type an A, I just want to type string quotes.

Elphi

2007-09-24 11:10

reporter   ~0014876

Ah, now I understand what you mean: 'dead keys'. Dead keys are enabled but this is not the point. If I hit ' (single quote) then IMMEDIATELY A´ (A followed by accent acute) is displayed. The cursor is located between both characters.
I don't get this behavoir with win xp 32 on the same machine, nor do I get it with other editors like this one or gnome's text viewer.

Bart Broersma

2008-03-10 12:21

developer   ~0018266

This problem was discussed on the Lazarusforum (http://www.lazarus.freepascal.org/index.php?name=PNphpBB2&file=viewtopic&t=4671).
It is on the Road to 1.0 also (http://wiki.lazarus.freepascal.org/Road_To_1.0), and Mattias seems to be responsible for this feature.

As for now turning dead keys off if you work in the Lazarus IDE seems the way to work around it (you can toggle this in a simple shell script).

Bart Broersma

2009-11-18 15:20

developer   ~0032254

This seems to have been fixed in the mean time (tested with Laz 0.9.29 r22953/fpc 2.2.4 on Linux GTK2)?
Elphi, can you retest and report back?

Elphi

2009-11-26 13:00

reporter   ~0032493

I've abandoned the x86_64 platform, so I can't test it.

Vincent Snijders

2009-11-26 13:24

manager   ~0032496

Then I resolve the issue.

Issue History

Date Modified Username Field Change
2007-09-23 14:02 Elphi New Issue
2007-09-23 14:02 Elphi Widgetset => GTK
2007-09-23 14:48 Thaddy de Koning Note Added: 0014863
2007-09-23 14:50 Thaddy de Koning Note Edited: 0014863
2007-09-23 18:30 Vincent Snijders LazTarget => 1.0
2007-09-23 18:30 Vincent Snijders Note Added: 0014866
2007-09-23 18:30 Vincent Snijders Status new => feedback
2007-09-24 00:23 Elphi Note Added: 0014872
2007-09-24 11:10 Elphi Note Added: 0014876
2008-03-10 11:32 Vincent Snijders Status feedback => acknowledged
2008-03-10 12:21 Bart Broersma Note Added: 0018266
2008-04-24 09:57 Vincent Snijders Target Version => 1.0.0
2009-11-18 15:20 Bart Broersma Note Added: 0032254
2009-11-18 15:20 Bart Broersma Status acknowledged => feedback
2009-11-26 13:00 Elphi Note Added: 0032493
2009-11-26 13:24 Vincent Snijders Status feedback => resolved
2009-11-26 13:24 Vincent Snijders Resolution open => no change required
2009-11-26 13:24 Vincent Snijders Assigned To => Vincent Snijders
2009-11-26 13:24 Vincent Snijders Note Added: 0032496
2009-12-02 12:07 Bart Broersma Relationship added duplicate of 0007742
2009-12-02 12:07 Bart Broersma Relationship added duplicate of 0007017
2009-12-02 12:07 Bart Broersma Relationship added duplicate of 0008855
2009-12-02 12:08 Bart Broersma Relationship added duplicate of 0001186
2010-04-23 11:23 Bart Broersma Status resolved => closed